Portal-Zone Gothic-Zone Gothic II-Zone Gothic 3-Zone Gothic 4-Zone Modifikationen-Zone Download-Zone Foren-Zone RPG-Zone Almanach-Zone Spirit of Gothic

 

Seite 14 von 14 « Erste ... 371011121314
Ergebnis 261 bis 274 von 274
  1. Beiträge anzeigen #261 Zitieren
    Ranger Avatar von Mark56
    Registriert seit
    Sep 2010
    Beiträge
    188
     
    Mark56 ist offline
    Its because of gothic . gothic uses models in this state... To fix it you need to weld verticles.
    there is even option while importing model, asking you if you want to weld them after import

  2. Homepage besuchen Beiträge anzeigen #262 Zitieren
    Ranger Avatar von DRMProd
    Registriert seit
    Oct 2009
    Ort
    Argentina
    Beiträge
    119
     
    DRMProd ist offline
    Hi, I'm using Blender 2.66 on ubuntu, and I can't get the program to import anything at all. Maybe I'm being dumb and this is a stupid question but, do you have any idea what's going on? Are the pluggins not compatible with the linux version of Blender?
    Edit: Ok, i've taken a look at the console output and it says that (obviously) can't execute wxImpExpUI.exe. If there is a way to use these plugins under linux, please give me a heads up
    Here's my terminal output:
    ubuntu@ubuntu-pieza:~$ blender
    Color management: using fallback mode for management
    connect failed: No such file or directory

    Note: No (valid) '/home/ubuntu/.config/blender/2.66/config/startup.blend' found, fall back to built-in default.

    Read new prefs: /home/ubuntu/.config/blender/2.66/config/userpref.blend
    sh: 1: /usr/share/blender/scripts/addons/KrxImpExpwxImpExpUI.exe /home/ubuntu/.config/blender/2.66/config//KrxImpExpDlgInput.bin /home/ubuntu/.config/blender/2.66/config//KrxImpExpDlgOutput.bin /home/ubuntu/.config/blender/2.66/config//KrxImpExpUI.cfg: not found
    Could not execute:
    /usr/share/blender/scripts/addons/KrxImpExp\wxImpExpUI.exe

    Error: Not freed memory blocks: 2
    IDProperty group len: 128 0x53b0518
    uiAfterFunc len: 272 0x53aa718

    Blender quit
    Geändert von DRMProd (24.11.2013 um 23:01 Uhr)

  3. Beiträge anzeigen #263 Zitieren
    Veteran
    Registriert seit
    Jan 2012
    Beiträge
    638
     
    Frank-95 ist offline
    Hi!

    Thanks for your job first of all. I would like to ask you two questions.

    First of all, are you going to release a versione of the plu-in for each blender version?

    Second: when I was using windows XP, the plug-in for gmax worked well, now that I'm oin windows 7 64 bit (but I've tried on windows 7 32 bit too), the script just doesn't work. As soos as I click on any button (I mean, any of the import/export button) that windows just disappear. I just can do nothing. Is it a known problem?

    Thank you

    EDIT: solved! I was not using the krximpexp launcher, but gmax's one :P
    Geändert von Frank-95 (11.09.2014 um 13:24 Uhr)

  4. Beiträge anzeigen #264 Zitieren
    Knight Avatar von catalinux
    Registriert seit
    Jan 2008
    Beiträge
    1.283
     
    catalinux ist offline
    Zitat Zitat von DRMProd Beitrag anzeigen
    Hi, I'm using Blender 2.66 on ubuntu, and I can't get the program to import anything at all. [...] Are the pluggins not compatible with the linux version of Blender?
    Edit: Ok, i've taken a look at the console output and it says that (obviously) can't execute wxImpExpUI.exe. If there is a way to use these plugins under linux, please give me a heads up
    I can confirm that KrxImpExp-blender2.66-Feb-25-2013 works without problems with blender-2.66-linux-glibc211. All you have to do is to extract or install KrxImpExp-blender2.66-Feb-25-2013 (in this second case use Wine to install KrxImpExp to a portable version of Blender for Windows, here you will find it archived as 7z or zip), than copy KrxImpExp directory including all files from it to you linux Blender /scripts/addons/

  5. Homepage besuchen Beiträge anzeigen #265 Zitieren
    Held Avatar von Zafiron
    Registriert seit
    Jan 2006
    Ort
    Irgendwo im Nirgendwo
    Beiträge
    5.842
     
    Zafiron ist offline
    Hi!

    first of all: thanks for all the work you have put into this project creating the Importer/Exporter!
    Yet I just ran into a problem: I could not find a working version for 3DS Max 2015 which I have to use. Is there any way I can get the Version for 3DS Max 2013 to work with 2015?
    I have seen that when loading, the imp/exporter won't load because the wrong version of the program has been found. Maybe the exporter would still work as it only appears to be a Version check!
    Maybe one just would need to remove the version check and then recompile the source?...

    Thanks for any answers!

  6. Beiträge anzeigen #266 Zitieren
    Veteran Avatar von Lmoere
    Registriert seit
    Jan 2008
    Ort
    Schleswig-Holstein
    Beiträge
    631
     
    Lmoere ist offline
    Hi, I have a Problem with the KrxImpExp for Blender 2.66.

    I intelled it and activatet it the same way like in all prior versions.(just following the Kerrax Guide)

    I get the same krx Import and export options as usual (for Gothic: 3ds. asc. etc,) But when I want to export or import a file. The progress just stops and blender does nothing.

    I tried all .exe versions of 2.66 and 2.66a. and the krxImpExp plugin files seem to be wher they belong.

    It would be great if somebody knew how to fix this Problem.

    NG Lmoere

    note: Sorry for the Uncanny Language.
    Es ist unsinnig keine Hoffnung zu haben, denn eine Zukunft ohne Hoffnung ist wie eine Welt ohne Sinn: vernachlässigbar.
    Es ist immer besser wenn die eigene Realität näher an der tatsächlichen liegt.
    Es gibt für dich unendlich viele Wege um alles zu erreichen.
    chop chop und los

  7. Homepage besuchen Beiträge anzeigen #267 Zitieren
    Knight Avatar von Kellendil
    Registriert seit
    Jul 2009
    Beiträge
    1.777
     
    Kellendil ist offline
    Hello,

    i have a different problem with KrxImpExp for Blender 2.66. Everything works fine on windows, but on Linux i get the following exception:
    Code:
      File "/opt/tomcat/apache-tomcat-8.0.24/blender/2.74/scripts/addons/KrxImpExp/image_search.py", line 140, in get_config_filepath 
        return bpy.utils.user_resource("CONFIG").rstrip(os.sep + os.altsep) + os.sep + "TextureDirs.cfg" 
    TypeError: Can't convert 'NoneType' object to str implicitly
    I think 'os.altsep' is 'None' on Linux (its 'slash' on Windows), and thus I get this error.

    I tested this with these Blender versions : 2.66a, 2.69b, 2.72, 2.74
    Always the same error. It´s not possible to import a 3DS file using Linux (Mint 17.1), Blender version doesn´t matter.
    Geändert von Kellendil (16.04.2016 um 05:38 Uhr)

  8. Beiträge anzeigen #268 Zitieren
    Ritter Avatar von Neconspictor
    Registriert seit
    Jan 2009
    Beiträge
    1.878
     
    Neconspictor ist offline
    First of all: I never programmed in python, so what i suggest now could be completely wrong.
    But as Kerrax and Magoth haven't been online for a while, maybe my assumption could help:

    Go to the file image_search.py and replace on line 138 this code:

    Code:
    #  Function: Gets path to configuration file
    def get_config_filepath():
         return bpy.utils.user_resource("CONFIG").rstrip(os.sep + os.altsep) + os.sep + "TextureDirs.cfg
    with this:

    Code:
    #  Function: Gets path to configuration file
    def get_config_filepath():
        if (os.altsep != None):
            return bpy.utils.user_resource("CONFIG").rstrip(os.sep + os.altsep) + os.sep + "TextureDirs.cfg"
        return bpy.utils.user_resource("CONFIG").rstrip(os.sep) + os.sep + "TextureDirs.cfg"
    Watch out that the indentation of each line is stated as above (python needs this for proper if statement switching).

    Let us know if it works!
    [Bild: banner_small.gif]

    Das Legend of Ahssûn - Team sucht wieder neue Leute.
    Hilf mit, eines der ältesten Modprojekte von Gothic 2 fertigzustellen.
    Auch Langzeittester sind gefragt!

  9. Homepage besuchen Beiträge anzeigen #269 Zitieren
    Knight Avatar von Kellendil
    Registriert seit
    Jul 2009
    Beiträge
    1.777
     
    Kellendil ist offline
    Zitat Zitat von Neconspictor Beitrag anzeigen
    Let us know if it works!
    Today i tried again after i tried a lot yesterday (i just deleted +os.altsep from the line to reduce any chance of syntax errors).

    You HAVE TO delete the __pycache__ folder inside the plugin´s folder, otherwise blender will still execute the original code and throw the same error (even though it will show you the new code in the error description).

    If you do that, you won´t get an error anymore, but nothing will happen. It seems like the Import-Dialogue-GUI is not working, so you have to execute the import without GUI:
    Select the console view and enter:
    Code:
    bpy.ops.import_scene.krx3dsimp(filepath ="<your_file_path>", quiet = True)
    The quiet part is important (it will import the file without import dialog using default settings i guess). This did it for me, thanks.

    Edit: I uploaded the fixed script:
    https://github.com/Katharsas/GMM/blo...search.py#L140
    Geändert von Kellendil (16.04.2016 um 22:12 Uhr)

  10. Beiträge anzeigen #270 Zitieren
    Warrior Avatar von mathúin
    Registriert seit
    Sep 2009
    Ort
    Italy
    Beiträge
    450
     
    mathúin ist offline
    I need to view some .mdm and .mrm files, I've download Blender 2.66 and installed the plugin (http://krximpexp.sourceforge.net/), enabled it into the software but I can't open them anyway. Help?

  11. Beiträge anzeigen #271 Zitieren
    Veteran
    Registriert seit
    Jan 2012
    Beiträge
    638
     
    Frank-95 ist offline
    You have to enable it. By memory, you have to go to user preferences -> addon -> and you will see a lot of disabled plugins. Just look for krximpexp, enable it, and in the left corner there should be something like save preference or something like that.

    By the way, you cannot open mdm files via blender. You should decompile them via gothic sourcer (you should decompile the msb file), but it's a little bit tricky if you don't know how to do it, or if the developer didn't compile them properly

  12. Beiträge anzeigen #272 Zitieren
    Warrior Avatar von mathúin
    Registriert seit
    Sep 2009
    Ort
    Italy
    Beiträge
    450
     
    mathúin ist offline
    In ANIMS and MESHES folders I have only .mdm and .mrm files. No .msb. And I found out how to decompile in GothicSourcer.
    [Bild: 2016-06-27_113327.png]

    P.S.: Really no time to come on Skype? It'd be a matter of seconds.

  13. Beiträge anzeigen #273 Zitieren
    Ritter Avatar von Degenerated
    Registriert seit
    Aug 2014
    Beiträge
    1.961
     
    Degenerated ist offline
    ZenLib can load these files. Here is some sample-code on how to do this:
    https://github.com/degenerated1123/Z...ntent_load.cpp

    However, you'll need to export them into a readable format yourself (via C++), or I could put a simple file-viewer into the REGoth-Engine, if you only need to look at the files.

  14. Beiträge anzeigen #274 Zitieren
    Warrior Avatar von mathúin
    Registriert seit
    Sep 2009
    Ort
    Italy
    Beiträge
    450
     
    mathúin ist offline
    Yes, I only need to look at them, no editing. So I'll use REGoth-Engine, but I need help there as well. If you could come on Steam it'd be better.

Seite 14 von 14 « Erste ... 371011121314

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
Impressum | Link Us | intern
World of Gothic © by World of Gothic Team
Gothic, Gothic 2 & Gothic 3 are © by Piranha Bytes & Egmont Interactive & JoWooD Productions AG, all rights reserved worldwide