Results 1 to 11 of 11

Signatur mit mehreren URLs

  1. #1 Reply With Quote
    Klatschfettig Defc's Avatar
    Join Date
    Dec 2002
    Location
    Bielefeld/Hameln
    Posts
    5,002
    Moin.

    Mir ist aufgefallen, dass sich mein Signatur-Layout (Schriftgröße, Fett- und/oder Kursivdruck) total zerschießt, wenn ich versuche, zwei URLs mit dem URL-Tag einzubinden.

    Bei der ersten URL klappt das noch ohne Probleme, füge ich dann eine weitere URL (mit Tags) hinzu, sehe ich teilweise die Tags für die Größe der Schrift (Size) oder der neu eingefügte URL-Tag wird inkorrekt angezeigt (zum Beispiel so, dass ich die Tags direkt sehe).

    Mache ich was falsch oder ist das so gewollt?

    Ich habe die URLs nacheinander einfügen wollen, also die erste URL eingefügt, Layout angepasst, gespeichert und dann die nächste URL - ab da spinnt dann die Ansicht und zerschießt mir mein Layout (wenn man das Layout nennen kann ).
    Defc is offline

  2. #2 Reply With Quote
    Knight Küken's Avatar
    Join Date
    Apr 2006
    Posts
    1,289
    Sollte eigentlich fehlerfrei klappen. Zeig doch mal, was du da eingibst. Du kannst das Forum daran hindern, den Code zu parsen, indem du ihn mit Noparse-Tags umschließt:

    [noparse][url=https://www.example.com][color=red]example[/color][/url][/noparse]
    Küken is offline

  3. #3 Reply With Quote
    Klatschfettig Defc's Avatar
    Join Date
    Dec 2002
    Location
    Bielefeld/Hameln
    Posts
    5,002
    Ich gebe es wie folgt ein:

    [*url=LINK] TEXT [*/url] (ohne die *)

    Darunter hab ich dann einen normalen Text gesetzt und alles auf Schriftgröße 1 verkleinert, mit Fettdruck.

    Wenn ich nach dem speichern dann eine weitere URL (wie oben) einfügen möchte, zerschießt es mir das Layout und ich sehe teilweise die Tags (egal ob URL/Size/Bold).
    Defc is offline

  4. #4 Reply With Quote
    Knight Küken's Avatar
    Join Date
    Apr 2006
    Posts
    1,289
    Mich interessiert jetzt weniger das grobe Schema, ich hätte gern einen Blick auf den tatsächlichen Code geworfen, den du da eingegeben hast und der das Layout zerschießt. Ansonsten kann ich dir auch nur sagen, dass es eigentlich funktionieren müsste.

    Ich habe mal testweise eine eigene Signatur gesetzt - klappt auf Anhieb.
    Küken is offline

  5. #5 Reply With Quote
    Klatschfettig Defc's Avatar
    Join Date
    Dec 2002
    Location
    Bielefeld/Hameln
    Posts
    5,002
    Hast du die Signatur denn in einem Rutsch erstellt oder so wie ich in "Etappen"?

    Im Grunde gehe ich wie folgt vor:

    Den URL-Tag mit dem eigenen Text in der Mitte gebe ich manuell ein. Anschließend tippe ich unter die URL meinen eigenen Text, markiere beides, wähle "fettdruck" und "Schriftgröße 1" über die Buttons aus und speichere.

    Danach sieht alles schick aus. Nun gehe ich erneut in die Signatur und will unter meinen bestehenden Link erneut eine URL mit eigener Bezeichnung (also via URL-Tag) einfügen, was ich erneut manuell tue.
    Wenn ich dann speichern will, zerschießt sich das Layout, ich sehe die Tags und muss alles erneut eintippen.

    Werde nach der Mittagspause mal "den Vorgang" nachstellen und dir Screenshots posten. Die Tags für den Fettdruck und die kleinere Schriftart sieht man da allerdings nicht, weil ich das wie erwähnt direkt über die Buttons mache (Bereich markieren, Button und Einstellung wählen, fertig).
    Defc is offline

  6. #6 Reply With Quote
    Knight Küken's Avatar
    Join Date
    Apr 2006
    Posts
    1,289
    Ah. Die Buttons habe ich bei mir wegkonfiguriert, ich tippe sowas von Hand.
    Ich habe das tatsächlich in einem Rutsch erledigt.

    Du bist mir immernoch den Code schuldig. Ich vermute, dass da einfach was in der falschen Reihenfolge drin steht und das Forum das deshalb nicht korrekt parsen kann.
    [url][color][/color][/url] funktioniert, [url][color][/url][/color] ist kaputt.
    Küken is offline

  7. #7 Reply With Quote
    Klatschfettig Defc's Avatar
    Join Date
    Dec 2002
    Location
    Bielefeld/Hameln
    Posts
    5,002
    Dann müsste ich also so vorgehen, wie bisher, die Buttons für die Schriftgröße und den Fettdruck nutzen, vor den Texten/Wörtern noparse setzen und dann im Preview die Codes sehen, korrekt?

    Verzeih meine Unwissenheit.

    Im Grunde nutze ich sonst gar nichts, also keine Farben oder ähnliches. Ich nehme wirklich nur den URL-Tag (manuell) und passe die Schriftgröße und den Fettdruck über die Buttons an, mehr nicht.
    Defc is offline

  8. #8 Reply With Quote
    Forenkater Matteo's Avatar
    Join Date
    Dec 2003
    Location
    Khorinis
    Posts
    14,362
    Quote Originally Posted by Defc View Post
    Die Tags für den Fettdruck und die kleinere Schriftart sieht man da allerdings nicht, weil ich das wie erwähnt direkt über die Buttons mache (Bereich markieren, Button und Einstellung wählen, fertig).
    Und genau da liegt vermutlich das Problem: Falsch verschachtelte tags, was sehr leicht passieren kann, wenn man den WYSIWYG-Editor verwendet, wo man die meisten tags eben nicht sieht.
    Stell mal den Editormodus um (Button links oben überm Textfeld), damit alle tags angezeigt werden. Dann siehst du das Problem entweder selbst bzw. kannst dann den kompletten Inhalt des Editors hier posten und wir sehen das Problem.
    Matteo is offline

  9. #9 Reply With Quote
    Knight Küken's Avatar
    Join Date
    Apr 2006
    Posts
    1,289
    Ich sehe gerade, dass es mittlerweile einen WYSIWYG-Editor gibt. Vermutlich nutzt du den? Dann verstehe ich, warum wir hier so mehr oder weniger aneinander vorbei reden.
    Das Ding ist ja fürchterlich.

    Ich habe damit aber gerade in mehreren Schritten meine Signatur bearbeitet. Hat auch auf Anhieb funktioniert. Ich kann deinen Fehler nicht nachvollziehen. Da wäre ich dann tatsächlich an Screenshots interessiert.

    Ansonsten wäre vermutlich die einfachste Lösung, dass du entweder einen anständigen Editor verwendest () oder den folgenden Code kopierst, die URLs entsprechend anpasst und das dann im Textfeld deines Signatureditors eingibst und speicherst.

    [size=1][b][url=https://example.com].com[/url] [url=https://example.net].net[/url]
    Zweite Zeile[/b][/size]
    Küken is offline

  10. #10 Reply With Quote
    Klatschfettig Defc's Avatar
    Join Date
    Dec 2002
    Location
    Bielefeld/Hameln
    Posts
    5,002
    Ja, ich nutze genau diesen Editor.

    Probiere eure Ratschläge mal, allerdings bin ich jetzt erstmal in Terminen und weiß nicht, ob ich das heute noch schaffe.

    Da ich zu Hause nur via Smartphone zugreife, kann ich dann frühestens Montag Meldung geben.
    Defc is offline

  11. #11 Reply With Quote
    Klatschfettig Defc's Avatar
    Join Date
    Dec 2002
    Location
    Bielefeld/Hameln
    Posts
    5,002
    Es hat übrigens mit dem normalen Basic-Editor geklappt. Im erweiterten (dynamischen) Editor klappt das Einbinden allerdings nicht, da er mir hier immer wieder die Tags anzeigt oder das Layout der Signatur zerschießt.

    Ich stelle den Editor gleich mal um, hoffentlich bleibt die Signatur dann aber "stabil".


    EDIT

    Okay, sobald der WYSHSHSHDGSHSSWH-Editor ausgeschaltet ist, klappt die Einbindung mehrerer Links und Tags ohne Probleme (manuell).
    Es ist so zwar etwas umständlicher, aber wenn es nicht anders geht, kann ich natürlich auch damit leben. Wieso der erweiterte Editor so fehlerhaft ist, weiß ich zwar nicht, aber vielleicht bin ich auch einfach zu dösig um ihn korrekt zu benutzen.

    Danke für eure Hinweise/Tipps, werte Gentleman!
    Defc is offline Last edited by Defc; 07.05.2020 at 08:31.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •