I have very frustrating problem. When I set Shadows Off in Game Settings torch doesn't generate light, so in night, caves and darker places I see nothing. But when I set Shadows On (even on Low settings) torch generates light without any problem. Unfortunetly, Shadows On causing drop performance so badly and I have to stay with Shadows Off.
Is there any way to make torch generates light with Shadows Off settings?

PC specification:
GeForce 820m, 2GB
Intel i3-4000m, 2.40GHz