Home Risen Risen2 Risen3 Forum English Russian

Register FAQ Calendar Today's Posts
Results 1 to 5 of 5
  1. #1 Reply With Quote
    Waldläufer oneeypi's Avatar
    Join Date
    Jan 2005
    Location
    In the Middle of Nowhere
    Posts
    119
    Hallo zusammen,
    ich versuche gerade Risen 1 ans laufen zu bekommen und hänge leider an der Auflösungseinstellung.
    In der AppData\Local\Risen\ConfigUser.xml habe ich meine native Auflösung eingetragen. Sie wird im Spiel auch dargestellt, allerdings habe ich wie einen Kreis um die Mitte des Bildes.
    Meine Versuche <Aspect16x9 ...> anzupassen (wie es auf diversen Seiten empfohlen wird) sind leider fehlgeschlagen.
    Der Kreis ist sowohl im Menü, als auch ingame zu sehen. Das Spiel geht hinter dem Kreis weiter, jedoch kann man z.B. das Inventar kaum sehen.

    Hier noch ein Bild wie das ganze aussieht:
    https://upload.worldofplayers.de/files11/risen.png

    Danke und grüße
    oneeypi is offline

  2. #2 Reply With Quote
    Metasyntaktische Variable  foobar's Avatar
    Join Date
    Sep 2004
    Location
    Direkt hinter dir! Buh!
    Posts
    21,180
    Das sieht wie Vignettierung aus. IMHO ein dämlicher Trend der Branche, nämlich das künstliche Reproduzieren der Abbildungsfehler optischer Kameras, damit das Spiel "filmischer" wirkt (wie bspw. auf Depth of Field, Lensflare und einige andere Dinge). Den PB offenbar nachahmen musste. Weil macht man halt heute so.

    Ich habe nur im Moment keine Idee, wie man das beheben könnte. Du könntest versuchen, das Post-Processing abzuschalten. Allerdings führt das zu anderen Grafikproblemen (bspw. war Fensterglas dann pink statt durchsichtig, wenn ich mich recht entsinne).
    foobar is offline

  3. #3 Reply With Quote
    Waldläufer oneeypi's Avatar
    Join Date
    Jan 2005
    Location
    In the Middle of Nowhere
    Posts
    119
    Hey,

    also ich habe es mit dem deaktivieren von PostProcessing in den ini-Dateien probiert.
    Leider bringt es keine Abhilfe. Selbst auf der höchsten nativen Auflösung im Spiel (Schwarze Balken links und rechts) habe ich einen kleinen Ring um das Bild..

    Hier nochmal 2 Bilder:
    [Bild: risen_ultrawide_menu.png]
    [Bild: risen_ultrawide_ingame.png]

    In der ConfigDefault.xml habe ich den Eintrag zu Aspect16x9 so geändert:
    <Aspect16x9
    VirtalWidth="1820"
    VirtalHeight="768"
    EnableDrawScale="True"
    >
    und in der ConfigUser.xml habe ich nur die Auflösung angepasst:
    <Window
    AdapterNumber="0"
    Bottom="1440"
    Left="0"
    RefreshRate="100"
    Right="3440"
    Top="0"
    >


    Falls es noch Ideen gibt immer her damit

    Frohe Weihnachten
    oneeypi is offline

  4. #4 Reply With Quote
    Metasyntaktische Variable  foobar's Avatar
    Join Date
    Sep 2004
    Location
    Direkt hinter dir! Buh!
    Posts
    21,180
    Wenn es kein Postprocessing/Shadereffekt ist, dann ist es vielleicht eine Textur, die über das Spiel gelegt wird. In dem Fall könnte man die Spieldaten entpacken, darin nach der entsprechenden Textur suchen und sie dann durch eine komplett transparente Version ersetzen. Nebenan im Modifikationen-Forum finden sich eine Reihe von Tools der Community, mit denen man an die Spieldaten gelangen und Texturen konvertieren kann. Wird aber vermutlich in Bastelei ausarten.

    Ein anderer Ansatz könnte Overscanning sein. Das erfordert aber dann wohl eine entsprechende Unterstützung durch den Grafiktreiber. Die Idee wäre, im Spiel bzw. unter Windows eine höhere Auflösung einzutragen (sagen wir mal z.B. 5160x2160) und dann dem Treiber zu verklickern, dass er davon nur einen 3440x1440 Pixel großen Ausschnitt anzeigen soll. Dann sind die dunklen Bereiche zwar noch da, liegen aber im Randbereich außerhalb des Monitors und sind nicht mehr sichtbar. Vermutlich kostet das aber zusätzliche Leistung, weil die nicht sichtbaren Pixel vermutlich trotzdem berechnet werden müssen. Bei NVidia-Karten gibt es da eine Einstellung in der NVidia-Systemsteuerung unter "Desktop-Größe und Position anpassen", die geeignet erscheint (nicht selbst getestet). Mit dem AMD-Treiber habe ich keine Erfahrungen.

    Mehr fällt mir im Moment auch nicht ein.
    foobar is offline

  5. #5 Reply With Quote
    Waldläufer oneeypi's Avatar
    Join Date
    Jan 2005
    Location
    In the Middle of Nowhere
    Posts
    119
    Hallo foobar,

    danke für deine Hilfe! Ich konnte das Problem durch deinen Tipp mit den Texturen lösen. Ich habe eine Texturmod installiert, die scheinbar mit der Auflösung nicht klar gekommen ist.

    Eine neuinstallation von Steam und schon was das Problem behoben. Hätte nicht gedacht, das durch Texturmodifikation so ein Problem entstehen kann. Aber nun kann ich zocken!

    Wünsche noch einen ruhen Abend und eine schöne Weihnachtszeit
    oneeypi is offline

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •