Home Risen Risen2 Risen3 Forum English Russian

Registrieren Hilfe Kalender Heutige Beiträge
Ergebnis 1 bis 8 von 8
  1. #1 Zitieren
    Schwertmeister Avatar von CzarnyAfgan
    Registriert seit
    Jun 2010
    Ort
    Warsaw, Poland
    Beiträge
    746
    https://www.youtube.com/watch?v=9Ke4480MicU

    As you know, I've got issues

    First of all: custom meshes, that appear in black depending of camera angle or distance from object ( mesh ).

    Any freakin idea why ?

    [Bild: issuesjpg_qxhxwqw.jpg]

    [Bild: issues2jp_qxhxwqs.jpg]
    CzarnyAfgan ist offline

  2. #2 Zitieren
    Ehrengarde Avatar von Baltram
    Registriert seit
    Jun 2006
    Beiträge
    2.192
    Zitat Zitat von CzarnyAfgan Beitrag anzeigen
    First of all: custom meshes, that appear in black depending of camera angle or distance from object ( mesh ).

    Any freakin idea why ?
    If you send me the data (sector, layer, mesh) I can take a look and maybe find out what the problem is.
    Baltram ist offline

  3. #3 Zitieren
    Schwertmeister Avatar von CzarnyAfgan
    Registriert seit
    Jun 2010
    Ort
    Warsaw, Poland
    Beiträge
    746
    OK
    CzarnyAfgan ist offline

  4. #4 Zitieren
    Ehrengarde Avatar von Baltram
    Registriert seit
    Jun 2006
    Beiträge
    2.192
    There seems to be a problem with some of the ._xmsh files created with Rimy3D.

    I wrote a small programm to fix this: XmshFixer1.zip
    If one of your meshes sometimes appears in black (like ST_Tree_Dead_S_01._xmsh), drag it onto XmshFixer.exe and restart Risen.

    Let me know if it works!
    Baltram ist offline

  5. #5 Zitieren
    Schwertmeister Avatar von CzarnyAfgan
    Registriert seit
    Jun 2010
    Ort
    Warsaw, Poland
    Beiträge
    746
    Thanks ! I`ll check and let you know.
    CzarnyAfgan ist offline

  6. #6 Zitieren
    Schwertmeister Avatar von CzarnyAfgan
    Registriert seit
    Jun 2010
    Ort
    Warsaw, Poland
    Beiträge
    746
    It works fine now!

    [Bild: Snapshot2_qxrxwae.jpg]

    Thanks Baltram!
    CzarnyAfgan ist offline

  7. #7 Zitieren
    Schwertmeister Avatar von CzarnyAfgan
    Registriert seit
    Jun 2010
    Ort
    Warsaw, Poland
    Beiträge
    746
    Another problem:

    When I place static objects, which trigger animation "on click" as benches or beds ( when you click on them, player actor approaches them and triggers next even in animation chain like sitting or laying ). The problem is: objects as beds or chests work like a charm, but when I want to start the animation corresponding to bench ( when I click on it ), the player character starts animation ( for like 0,5 sec ) but then aborts it and nothing happens.

    I've checked the ground and bench collisions and they seem to be ok ( they don't look like they cross ), I've used DynEntity RecalcExtents command on bench entity aswell and still no effect.

    [Bild: Snapshot2_qxxhpee.jpg]

    [Bild: Snapshot2_qxxhpes.jpg]

    [Bild: Snapshot2_qxxhpea.jpg]
    CzarnyAfgan ist offline

  8. #8 Zitieren
    Ehrengarde Avatar von Baltram
    Registriert seit
    Jun 2006
    Beiträge
    2.192
    Such objects need to be inside a NavZone, otherwise NPCs (and also the hero) will not be able to position themselves correctly for the interaction to play out.
    Baltram ist offline

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •