Home Risen Risen2 Risen3 Forum English Russian

Register FAQ Calendar Today's Posts
Results 1 to 5 of 5
  1. #1 Reply With Quote
    Lehrling
    Join Date
    Mar 2015
    Posts
    47
    So, i have completed Risen 3: Titan Lords 3 times before Enchanted Edition came out on my old computer and it works fine, and looks good. Now i just checked how EE works on my new computer an... I'm little disappointed.

    Yes, it works fine, with all details on i didn't had even one drop below 60 fps but i just realized that game have FPS lock on 62 fps when v-sync is off. Also most of graphic options makes no difference. Just compare this screenshots: http://imgur.com/a/V50hu

    Can you see what option i have changed? It's Viewable Landscape Distance from low to high and i cant even say which is which. Many other options doesn't make difference too, which is sad. I can't check is changing anything affects on performance, because no matter what i try to do i have always 62 fps.
    xenonisbad is offline

  2. #2 Reply With Quote
    foobar is offline

  3. #3 Reply With Quote
    Lehrling
    Join Date
    Mar 2015
    Posts
    47
    Sorry, i forgot to make a queston :O

    So, is there a way to unlock fps lock?
    xenonisbad is offline

  4. #4 Reply With Quote
    Metasyntaktische Variable  foobar's Avatar
    Join Date
    Sep 2004
    Location
    Direkt hinter dir! Buh!
    Posts
    21,220
    Did you try your luck with the configuration file?

    Possibly interesting settings might be:

    Code:
    <global>
      <Engine>
        [...]
        <Window Top="0" SafetyFramePercentage="0.0" Right="1024" RefreshRate="0" Name="Risen 3 - Titan Lords" Left="0" FullScreen="false" FPSLimitToRefreshRate="true" FPSLimit="0" Center="false" CaptureCursor="true" Bottom="768" AdapterNumber="0">
        </Window>
        [...]
        <Timer MinFPS="10.00" MaxFPS="120.00" FixedFPS="-1.00" AverageFPS="30.00">
        </Timer>
        [...]
    foobar is offline

  5. #5 Reply With Quote
    Lehrling
    Join Date
    Mar 2015
    Posts
    47
    Thanks a lot! Earlier I've tried changing MaxFPS and AverageFPS from ConfigDefault.xml, I've even tried changing RefreshRate from ConfigUser.xml, and none of this works. Changing FPSLimitToRefreshRate to false disable a lock, which solve my problem. Thanks!
    xenonisbad is offline

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •