Portal-Zone Gothic-Zone Gothic II-Zone Gothic 3-Zone Gothic 4-Zone Modifikationen-Zone Download-Zone Foren-Zone RPG-Zone Almanach-Zone Spirit of Gothic

 

Results 1 to 20 of 20
  1. View Forum Posts #1 Reply With Quote
    Lehrling
    Join Date
    Dec 2015
    Location
    Berlin
    Posts
    29
     
    Foofanu is offline

    Problem beim Start und beim Beenden von Gothic 3

    Hallo Leute!

    Ich habe folgendes merkwürdiges Problem und hoffe jemand kann mir da helfen.

    System:

    Win 7 Ultimate Edition SP1 64 Bit (alles Aktuell)
    Kaspersky Internet Security

    AMD FX-6300
    8 GB RAM
    Zotac GTX 470
    SSD-Harddisk
    Theatron Agrippa Soundkarte 5.1

    Treiber alle Aktuell.

    Ich habe Gothic 3 und Erweiterungen als Administrator in den Ordner C:/Spiele/Gothic 3 wie folgt installiert.

    1. Hauptspiel via DVD
    2. nur der Community Patch v1.75.14 Full*und das Gothic 3 v1.75 Update Pack*
    3. Questpaket v4.2* + Kompatibilitätsupdate für den Patch v1.75*
    4. Content-Mod v2.6.3*

    Wenn ich nun das Spiel als Administrator oder auch nicht Ausführen möchte, muss ich die Gothic3.exe zwei mal Ausführen, damit das Spiel startet. Bei einmaligem Ausführen passiert nichts.

    An dem Gothic 3 v1.75 Update Pack liegt es schon mal nicht, auch das Questpacket und die Content Mod habe ich schon weg gelassen. Das selbe!
    Community Patch v1.75.14 Full war immer installiert. Kaspersky Internet Security habe ich auch schon zum Installieren und zum Spielen spaßeshalber deaktiviert.

    Des weiteren läuft das Spiel nach dem Beenden im Hintergrund weiter, es lässt sich nur mit Herunterfahren des Systems beenden (erzwungenes Beenden). Mit den anderen Piranha Bytes Spielen, habe ich das Problem nicht.

    Gothic 3 läuft zwar ohne Probleme aber es nervt doch ganz schön...

    Könnte es sein, dass irgend eine Funktion aus dem Programm "XP Antispy" das Verursacht?
    Last edited by ModRes; 21.01.2016 at 17:03. Reason: Doppelpost zusammengeführt

  2. View Forum Posts #2 Reply With Quote
    Moderator Kretztech's Avatar
    Join Date
    Jul 2010
    Posts
    4,202
     
    Kretztech is offline
    Quote Originally Posted by Foofanu View Post
    Könnte es sein, dass irgend eine Funktion aus dem Programm "XP Antispy" das Verursacht?
    Wohl eher nicht.
    Sieh mal zu, dass du den Spiele-Explorer, welcher im Hintergrund mitläuft ruhigstellst.
    Solltest du diesen nicht anderweitig nutzen, sieh zu dass du diesen loswirst.

    War/Ist eines der ersten Dinge, welche ich nach einer erfolgreichen Windows 7-Installation gemacht habe. Also den Spiele-Explorer von der Platte schmeißen.

  3. View Forum Posts #3 Reply With Quote
    Lehrling
    Join Date
    Dec 2015
    Location
    Berlin
    Posts
    29
     
    Foofanu is offline
    Quote Originally Posted by Kretztech View Post
    Wohl eher nicht.
    Sieh mal zu, dass du den Spiele-Explorer, welcher im Hintergrund mitläuft ruhigstellst.
    Solltest du diesen nicht anderweitig nutzen, sieh zu dass du diesen loswirst.

    War/Ist eines der ersten Dinge, welche ich nach einer erfolgreichen Windows 7-Installation gemacht habe. Also den Spiele-Explorer von der Platte schmeißen.
    Danke!

    Ich habe den jetzt unter "Windows Funktionen" ausgeschaltet, also "Spiele" abgewählt.
    Dann noch die Verknüpfung im Startmenü und den Ordner im Benutzerkonto gelöscht.
    System neu gestartet.
    Mehr kann man da glaube ich garnicht machen.

    Das Problem besteht jedoch weiterhin. Kann natürlich sein, dass ich Gothic 3 danach nochmal neu installieren muss, damit es was bringt. Wer weiß?

    Gothic 3 ist wie gesagt auch das einzige Spiel, was solche Zicken macht.

  4. View Forum Posts #4 Reply With Quote
    Schwertmeister
    Join Date
    Dec 2013
    Location
    D ~Hannover
    Posts
    819
     
    BilboBeutlin is offline
    Guck mal im Taskmanager, ob da noch "rundll.. gameux.dll" läuft. Das ist der Game Explorer.
    Kann mich erinnern, dass ich damit auch viel Ärger hatte.
    Im Web gibt's einige 'Rezepte', wie man den Murks stillegt - such nach "gameux.dll"
    Löschen der gameux DLLs bringt nichts, die werden aus dem Win Backup wieder restauriert.
    'Verbieten' (mit regsvr ..) der DLL geht zwar, aber dann laufen uU. einige Games nicht mehr (die diese DLL selbst aufrufen).

    Bei mir hat's geholfen, sämtliche Spiele aus dem Game Explorer Verzeichnis zu entfernen und danach den Spiele/Games Ordner zu deaktivieren.
    Nach einer Game Neuinstall. muss man evtl. nochmal nachgucken, ob sich das Biest wieder reingemogelt hat.

    siehe auch hier

  5. View Forum Posts #5 Reply With Quote
    Lehrling
    Join Date
    Dec 2015
    Location
    Berlin
    Posts
    29
     
    Foofanu is offline
    Quote Originally Posted by BilboBeutlin View Post
    Guck mal im Taskmanager, ob da noch "rundll.. gameux.dll" läuft. Das ist der Game Explorer.
    Kann mich erinnern, dass ich damit auch viel Ärger hatte.
    Im Web gibt's einige 'Rezepte', wie man den Murks stillegt - such nach "gameux.dll"
    Löschen der gameux DLLs bringt nichts, die werden aus dem Win Backup wieder restauriert.
    'Verbieten' (mit regsvr ..) der DLL geht zwar, aber dann laufen uU. einige Games nicht mehr (die diese DLL selbst aufrufen).

    Bei mir hat's geholfen, sämtliche Spiele aus dem Game Explorer Verzeichnis zu entfernen und danach den Spiele/Games Ordner zu deaktivieren.
    Nach einer Game Neuinstall. muss man evtl. nochmal nachgucken, ob sich das Biest wieder reingemogelt hat.

    siehe auch hier
    Nein, bei mir läuft nur die normale "rundll.exe *32", unter Prozesse meine ich. Ich glaube die brauch man auch.

    Dafür habe ich gesehen, dass die Gothic3.exe, nach starten des Spiels zwei mal drin steht. Soll das so sein?
    Ich muss Sie ja auch 2 mal starten damit was passiert.
    Als ich Windows 7 neu drauf hatte, hatte ich das Problem ja auch nicht. Seit dem habe ich an der Konfiguration aber nichts geändert.

    Was für ein Käse.

    Vielen Dank für deine Mühe und Zeit!
    Ich denke ich installiere Windows 7 irgendwann nochmal komplett neu und versuche den Game-Explorer gleich am Anfang über die Windows-Funktionen zu deaktivieren und das beste zu hoffen. Das habe ich letztes mal nicht getan. "Spiele" können ja nicht schaden, dachte ich

    Alles andere was ich gelesen habe, kann ich nicht so recht umsetzen ohne größere Schäden an meinem System zu riskieren. Registry-Einträge löschen kann auch nach hinten los gehen.

    Allerdings startet der "rundll.exe *32" Prozess, auch wieder mit Gothic 3 nach beenden. Wenn ich "rundll.exe *32" beende, beende ich auch Gothic 3 mit.

    Ich habe echt keine Ahnung wie ich das Teil aus meinem System bekommen soll. Habe schon alles "normale" versucht.

    In der Registry steht auch nicht, dass der Game-Explorer beim Start von Gothic 3 geladen werden soll. Ich glaube ich gebe die Hoffnung auf...

    Mir ist aber noch etwas anderes aufgefallen als ich den Task-Manager offen hatte. Wenn ich das erste mal die "Gothic3.exe" ausführe, startet eine zweite "rundll.exe *32" und die erste Gothic3.exe im Task-Manager. Das Spiel startet jedoch nicht. Beim zweiten ausführen der "Gothic3.exe" startet wiederum eine zweite "Gothic3.exe" im Task-Manager und das Spiel startet. Kommt mir etwas ungewöhnlich vor. Soll das so?
    Last edited by ModRes; 21.01.2016 at 17:02. Reason: Quadpost zusammengeführt

  6. View Forum Posts #6 Reply With Quote
    Schwertmeister
    Join Date
    Dec 2013
    Location
    D ~Hannover
    Posts
    819
     
    BilboBeutlin is offline
    Nein - eigentlich nicht.

    Mit dem (ersten) Starten von G3 startet auch die "rundll.exe gameux.dll" (sieht ggf. unterschiedlich aus je nach System oder 32/64bit). Du musst im Taskmanager Ansicht -> Spalten -> Befehlszeile aktivieren, dann siehst du den kompl. Befehl.

    Diese 'gameux.dll' sucht im Internet nach Updates für das gestartete Spiel. Wenn man online ist, beendet sie sich idR. von alleine. Aber offline läuft der Task endlos und mit 100% Auslastung.

  7. View Forum Posts #7 Reply With Quote
    Lehrling
    Join Date
    Dec 2015
    Location
    Berlin
    Posts
    29
     
    Foofanu is offline
    Quote Originally Posted by BilboBeutlin View Post
    Nein - eigentlich nicht.

    Mit dem (ersten) Starten von G3 startet auch die "rundll.exe gameux.dll" (sieht ggf. unterschiedlich aus je nach System oder 32/64bit). Du musst im Taskmanager Ansicht -> Spalten -> Befehlszeile aktivieren, dann siehst du den kompl. Befehl.

    Diese 'gameux.dll' sucht im Internet nach Updates für das gestartete Spiel. Wenn man online ist, beendet sie sich idR. von alleine. Aber offline läuft der Task endlos und mit 100% Auslastung.
    Alles klar! Danke! Habe ich gesehen, das die Besagte mit angeht. So was blödes, ich habe bisher kein bewährtes Rezept gefunden die ruhig zu stellen. Das muss sich doch deaktivieren lassen...

    Ich meine ohne per "Regedit" rum zu popeln. Was soll das erst mit Win 10 werden?

    Ja! Mit aktivem Internet läuft das Spiel irgendwie besser und länger stabil. Jetzt weiss ich ja auch warum...Wieso?
    Last edited by Foofanu; 22.01.2016 at 22:59.

  8. View Forum Posts #8 Reply With Quote
    Schwertmeister
    Join Date
    Dec 2013
    Location
    D ~Hannover
    Posts
    819
     
    BilboBeutlin is offline
    Ich hab damals auch so einiges versucht, bis es sich dann selbst erledigt hatte, indem ich alle Games aus dem Game-Explorer-Verzeichnis entfernt hatte und danach den Game-Explorer selbst deaktiviert (Windows Einstellungen).

    Übergangsweise kann man sich behelfen, indem man G3 zweimal startet, dann im Taskmanager den Task "rundll.exe gameux.dll" abschiesst. Damit wird auch der erste G3 Task beendet und man kann mit dem zweiten weiterspielen.

    Sollte wohl auch funktionieren, die 'gameux.dll' zu verbieten.
    Dazu ne kleine Batch Datei:
    Code:
    regsvr32 -u c:\windows\system32\gameux.dll
    regsvr32 -u c:\windows\SysWOW64\gameux.dll
    Je nach System muss man evtl. die Pfade anpassen.

    Um die 'gameux.dll' wieder zuzulassen:
    Code:
    regsvr32 c:\windows\system32\gameux.dll
    regsvr32 c:\windows\SysWOW64\gameux.dll
    Das könnte uU. notwendig sein, wenn ein Game diese DLL selbst aufruft.

  9. View Forum Posts #9 Reply With Quote
    Moderator Kretztech's Avatar
    Join Date
    Jul 2010
    Posts
    4,202
     
    Kretztech is offline
    Quote Originally Posted by Foofanu View Post
    ...
    Es ist nur notwendig die gameux.dll und die GameUXLegacyGDFs.dll Datei, aus C:\Windows\System32 zu löschen. Damit ist der Spiele-Explorer zwar noch nicht gänzlich von der Platte gelöscht, aber er funktioniert nicht mehr. Die Reste kann man aber auch noch manuell löschen, wenn man es denn unbedingt möchte.

    Ich kann dir auch eine Schritt-für-Schritt-Anleitung geben, wenn du es selbst nicht schaffst.

    Quote Originally Posted by BilboBeutlin View Post
    Löschen der gameux DLLs bringt nichts, die werden aus dem Win Backup wieder restauriert.
    Bei mir hat es immer gereicht die Dateien zu löschen und da wurde nie etwas wiederhergestellt. Hab das Ganze auch schon weit mehr als nur einmal gemacht.
    Sollte es aber dennoch vorkommen, was ja nicht auszuschließen ist, kann man auch da Abhilfe schaffen.

  10. View Forum Posts #10 Reply With Quote
    Schwertmeister
    Join Date
    Dec 2013
    Location
    D ~Hannover
    Posts
    819
     
    BilboBeutlin is offline
    Einfaches Löschen hilft nicht (mehr) bei Windows nach XP.
    Schon bei XP gab es den Ordner 'DLLcache', aus dem bei Bedarf fehlende oder beschädigte Dateien restauriert wurden.
    Ab Vista gibt's dafür 'WinSxS' und 'WinSxS\Backup'.

    Für die Kontrolle sorgt der Windows-Dateischutz (Windows File Protection, WFP). Schon beim nächsten Neustart wird die gelöschte Systemdatei wieder ersetzt.

    Sollte man es geschafft haben, die entspr. Datei auch aus den Backups zu löschen, sorgt dann das nächste Windows Update für Restaurierung.

  11. View Forum Posts #11 Reply With Quote
    Moderator Kretztech's Avatar
    Join Date
    Jul 2010
    Posts
    4,202
     
    Kretztech is offline
    Quote Originally Posted by BilboBeutlin View Post
    Schon beim nächsten Neustart wird die gelöschte Systemdatei wieder ersetzt.
    Wie schon geschrieben, "bei mir nicht" und bei allen, wo ich es gemacht habe auch nicht. Ich habe sie gelöscht und sie blieben dann auch weg (auch nach Neustart).

    Der TE kann es ja zumindest versuchen. Warum etwas nur deaktivieren was man nicht nutzt oder haben will. Dann doch lieber gleich aus dem System löschen.

  12. View Forum Posts #12 Reply With Quote
    Schwertmeister
    Join Date
    Dec 2013
    Location
    D ~Hannover
    Posts
    819
     
    BilboBeutlin is offline
    Eigentlich wird jede DLL, die zB über 'regsvr32' registriert und zugelassen wurde, überwacht und ggf. ersetzt.
    Die Überwachung macht die WFP (Windows File Protection), ab Vista WRC (Windows Resource Protection) genannt. Diese ruft dann bei Bedarf "sfc.exe" (System File Checker) auf.

    Ich könnte mir allerdings vorstellen, dass in den Windows Professional/Business Editionen diese DLLs nicht als 'essential' markiert sind und deshalb nicht restauriert werden.

    Nach dem Motto "Versuch macht kluch" könnte man's mal probieren. Wenn's dann nicht funzt, weiss man woran's liegt.

  13. View Forum Posts #13 Reply With Quote
    Lehrling
    Join Date
    Dec 2015
    Location
    Berlin
    Posts
    29
     
    Foofanu is offline
    Quote Originally Posted by BilboBeutlin View Post
    Ich hab damals auch so einiges versucht, bis es sich dann selbst erledigt hatte, indem ich alle Games aus dem Game-Explorer-Verzeichnis entfernt hatte und danach den Game-Explorer selbst deaktiviert (Windows Einstellungen).

    Übergangsweise kann man sich behelfen, indem man G3 zweimal startet, dann im Taskmanager den Task "rundll.exe gameux.dll" abschiesst. Damit wird auch der erste G3 Task beendet und man kann mit dem zweiten weiterspielen.

    Sollte wohl auch funktionieren, die 'gameux.dll' zu verbieten.
    Dazu ne kleine Batch Datei:
    Code:
    regsvr32 -u c:\windows\system32\gameux.dll
    regsvr32 -u c:\windows\SysWOW64\gameux.dll
    Je nach System muss man evtl. die Pfade anpassen.

    Um die 'gameux.dll' wieder zuzulassen:
    Code:
    regsvr32 c:\windows\system32\gameux.dll
    regsvr32 c:\windows\SysWOW64\gameux.dll
    Das könnte uU. notwendig sein, wenn ein Game diese DLL selbst aufruft.
    Coole Sache, dass funktioniert. Ich denke das Game ruft die DLL selbst auf. Das mit dem Taskmanager geht auch, mit dem Batch ist aber schicker. Vielen Dank!

    Mit dem Löschen der beiden Dateien im Windows-Ordner funktioniert bei mir nicht, lässt Windows nicht zu. Konnte ich also nicht testen. Dazu muss man bestimmt erst etwas anderes deaktivieren. (Windows-Dateien-Schutz, Benutzerkontosteuerung o.ä.) Er erzählt immer was von wegen: Trustedinstaller Berechtigung fehlt.

    Danke nochmal an alle, für die vielen hilfreichen Tipps. Ihr seid klasse!

    Ein Freund von mir ist Programmierer, der konnte mir auch nicht helfen. Er hat mich nur ausgelacht, dass ich dieses Spiel so mag. Jedem dass seine sag ich mal.
    Last edited by ModRes; 27.01.2016 at 11:20. Reason: Doppelpost zusammengeführt

  14. View Forum Posts #14 Reply With Quote
    Schwertmeister
    Join Date
    Dec 2013
    Location
    D ~Hannover
    Posts
    819
     
    BilboBeutlin is offline
    Richtig!
    Und dein Freund, der 'Programmierer', gehört wohl zu denen, die es als 'meisterhaft' empfinden, 20 Zeilen LUA oder PHP zu stricken ohne dass der PC abstürzt. Sonst hätte er dir wohl mal ganz locker bei dem Problem helfen können.

    Man muss zwar mal deutlich sagen, dass G3 technisch 'von gestern' ist - angesichts der Entwicklung um 2005. Aber es gibt echte Klassiker, die trotz oder gerade wg. der aktuellen Neuentwicklungen immer noch Spass machen.

    Ich selbst schalte noch bisweilen mal meinen Commodore Amiga4000 oder C128 an, um ein paar Oldies zu daddeln.

  15. View Forum Posts #15 Reply With Quote
    Lehrling
    Join Date
    Dec 2015
    Location
    Berlin
    Posts
    29
     
    Foofanu is offline
    Er ist schon etwas arrogant der Typ. Finde ich gut! Ich steh auch auf Klassiker.
    Ich kann mich erinnern, als ich Mass Effect gespielt habe und es erst 2 Jahre auf dem Markt war, meinte er schon: "Ist doch voll alt!".
    Ältere Spiele machen mir oft mehr Spaß als neue. Die meisten "Macher" haben auch keine eigenen Ideen sondern klauen bloß und verpacken es neu.

    Neu heißt nicht gleich besser.
    Last edited by Foofanu; 27.01.2016 at 01:57.

  16. View Forum Posts #16 Reply With Quote
    Veteran Golden Void's Avatar
    Join Date
    May 2008
    Posts
    654
     
    Golden Void is offline

    ugly

    Hallo Leute,

    ich hoffe daß einer der Problemlöser hier noch am Leben ist . Habe nämlich dasselbe Problem und bekomme es nicht gebacken. Win7-64, Rechner ist normalerweise offline. Muß 2x starten und den verirrten Prozeß dann manuell abschießen. Kann ja wohl nicht wahr sein .

    Die REGSVR32-Befehle bringen bei mir keine Änderung und wie ich den Games Explorer abschalten oder deaktivieren kann ist mir unklar.
    Finde nur über die Windows-Hilfe zu diesem Games Explorer Ordner - da habe ich alle Spiele "ausgeblendet" (löschen geht ja nicht) und dort über Optionen alle Online-Aktivitäten abgeschaltet. Zusätzlich über die Windows-Funktionen dann alles mit "Spiele" deaktiviert und den zugehörigen Ordner im Benutzerkonto gelöscht. Hat alles nichts gebracht.

    Könnte mir bitte jemand eine Anleitung für Doofe geben? Ich weiß nicht mal wie ich den Spiele Explorer aufrufen könnte...

  17. View Forum Posts #17 Reply With Quote
    Schwertmeister
    Join Date
    Dec 2013
    Location
    D ~Hannover
    Posts
    819
     
    BilboBeutlin is offline
    Scheint jetzt etwas einfacher zu gehen. Da hat man (Microsoft) wohl etwas dran geschraubt.
    Als ich vor 1/2 Jahr Win7 neu installiert hatte (zzgl. aller Updates) brauchte ich nur im Start -> Eigenschaften -> Startmenü -> Anpassen den Punkt Spiele -> "Element niemals anzeigen" einstellen. Dann war Ruhe.

  18. View Forum Posts #18 Reply With Quote
    Veteran Golden Void's Avatar
    Join Date
    May 2008
    Posts
    654
     
    Golden Void is offline
    Quote Originally Posted by BilboBeutlin View Post
    Scheint jetzt etwas einfacher zu gehen. Da hat man (Microsoft) wohl etwas dran geschraubt.
    Als ich vor 1/2 Jahr Win7 neu installiert hatte (zzgl. aller Updates) brauchte ich nur im Start -> Eigenschaften -> Startmenü -> Anpassen den Punkt Spiele -> "Element niemals anzeigen" einstellen. Dann war Ruhe.
    Das was bei mir schon so eingestellt und das war wohl auch der Grund warum ich nur über die Hilfe dorthin gefunden hatte. Aber es hindert diese verfluchte RUNDLL32 nicht daran zu starten und für immer meine Prozessorkerne aufzufressen, bis ich sie manuell per Taskmanager abschieße...

  19. View Forum Posts #19 Reply With Quote
    Schwertmeister
    Join Date
    Dec 2013
    Location
    D ~Hannover
    Posts
    819
     
    BilboBeutlin is offline
    Unglücklicherweise hat Winzigweich die Game-Explorer Optionen weit verstreut und wer sich nicht auskennt, sucht sich nen Wolf.

    Mach mal GameEx Fenster auf: Ausführen -> explorer shell:::{ED228FDF-9EA8-4870-83b1-96b02CFE0D52}
    Unter Optionen stellst du ein: Nie online nach Updates .. suchen ..

  20. View Forum Posts #20 Reply With Quote
    Veteran Golden Void's Avatar
    Join Date
    May 2008
    Posts
    654
     
    Golden Void is offline
    Das führt mich zum gleichen Ordner - und diese Option war so gesetzt. Hatte sie scherzhalber auch schonmal umgeschaltet und dann wieder zurück, ändert jedoch alles nichts. Danke aber für Deine Hilfe! Das bestätigt mir immerhin daß ich alle Register gezogen hab und es hat sich damit auch klar rausgestellt daß mein PC was gegen mich hat...

    Habe mir jetzt ein Quick'n'dirty-Startskript für G3 geschrieben. Das startet das Spiel 2x, wartet kurz und schießt dann die RUNDLL32 wieder ab. Damit is Ruhe im Karton und auch der Nervenzusammenbruch abgewendet .

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
Impressum | Link Us | intern
World of Gothic © by World of Gothic Team
Gothic, Gothic 2 & Gothic 3 are © by Piranha Bytes & Egmont Interactive & JoWooD Productions AG, all rights reserved worldwide